Downloads and expansion audio - downloads dodgy

May 12, 2012, 08:18 PM posted in General Discussion

I see that CPod stores its audio on AWS - Amazon Web Services. I am pulling my hair out because it's like rolling the dice when jumping in and out of older lessons and hoping for the audio to work. Can you please talk to Amazon or do something?

One day, the audio on a lesson works, another day it doesn't. You click on the play button, nothing.

I know internet bandwidth and traffic problems are tough to deal with. If this can't be resolved, perhaps you can make the expansion audio downloadable so at least I can grab a copy while its working.

Profile picture
May 14, 2012, 07:46 AM

Are you in China? It seems that Amazon's service is great in most places but not China.

You might want to try 1) sign out and back into your account again. It have worked for many users who have similar problems. 2) Clear both your chache and cookies. 

We don't have any plans to make all the expansion downloadable as it would require quite a major overhaul of the system and might have unintended consequences. I'd sincerely suggest using a VPN. 

But try my two suggestions first and see if they work.

Profile picture

I'm in the US - I tried your two suggestions and sometimes they help, thanks, but sometimes they don't. I am currently using a VPN, but I've experienced similar problems with other services using AWS.

Usually the next day, things get back to normal though. Thanks.