ChinesePod still doesn't work on iPad

March 15, 2015, 09:43 PM posted in General Discussion

Several months ago, I purchased an iPad so that I could use ChinesePod other places besides sitting upright at my desk. However, much to my dismay, I found that ChinesePod did not work in an acceptable way on the iPad. At that time, the staff indicated they were working on it. Now, three months later, I find that it is still not working on iPad.

What happens is that the dialog starts, but just after the "translations" begin, it jumps back to the beginning of the dialog. This happens repeatedly. In addition, I tested it with both levels of sound resolution, and it happens with both.

Then, when I came to the website to find an email address to write to the staff again about this, I found that there are no email addresses or message boxes under "Contact" but only phone numbers. It is surprising that this is the case, since ChinesePod is working with customers in many different time zones, and customers who use ChinesePod at all hours of day and night and all days of the week within their own time zone; so even though there is a phone number in my time zone, it is of no use on a Sunday afternoon.

Can these matters be addressed? Thanks.

No comments yet.