Issues with some lessons audio cutting out or ending early

March 12, 2015, 03:36 PM posted in General Discussion

Hi CPod Team,

I typically like to download the lesson audio files to my phone so I can listen to them on the go without using up all my mobile data. I have had noticed this issue on and off recently where the lesson seems to end early or randomly cut to the next lesson partway through. I have mostly noticed this with the older Qing Wen lessons but have noticed it in recent regular lessons.

For example the most recent elementary (rebooking a dentist appointment) and intermediate lessons seem to cut off towards the end of the lesson before the hosts totally finished saying goodbye.

At first I thought that it was an issue with the download and have re-downloaded the files multiple times but still experience the same issue. I have noticed this downloading both through the CPod Android app but also manually downloading off the website and then copying to my phone.

One example lesson would be

This issue also sometimes happens when streaming  from the website on my PC but not always.

I had this QW 33 episode downloaded before and had issues on my phone and it would always abruptly end during the into.

Profile picture
March 13, 2015, 03:09 AM

This is very odd. Can I ask what phone you are using? I have just tried with the lessons you speak of on my HTC and Nexus and couldn't recreate the problem (that's not to say it's not a problem).

Does it happen always on the same episode, or randomly.  Does it always happen on the 又 又 show without fail and does it always truncate at the same point in the show, and when on the phone, are you using the Android app to play the audio, or playing it through another app? 

Sorry to ask such a barrage of tedious questions, but hopefully we can find the problem and suggest a fix.





Profile picture
March 13, 2015, 04:52 AM

Hey Gwilym, No worries on the barrage of questions, I work in IT and support questions like are something I am usually asking others on a daily bases. I understand the need for proper information and know what has been tested so i will try to provide the best and most detailed info I can on the testing I have done so far. I have a Oneplus One that I'm using right now but also tried it on my Dell Tablet and 2013 Moto X in the last few weeks. When using it on my Android devices and for each episode the issue always happened at the exact same point every time but each episode had the issue occur at different points in time. I have tried multiple android apps to play the audio including the official Google Music app and ES File Explorer. I had the exact same issue at the same point on both apps.

I wasn't able to find the specific Qing Wen episodes using the CPod Android app when searching the library so I couldn't test it there. I can say that with the recent episodes I did notice some truncation at the very end and this is when I used the only the app to download and play the lesson.

When streaming from the website using my PC it seemed random as I was able to refresh the page and manually click to the same timestamp/point I had the issue. After that it would play just fine from that point but sometimes still would stop again at a random point.

I will say that it the last time I downloaded a large amount of Qing Wen lessons was in end of December start of Jan while I was on vacation. I tried to download the又 又one more time just now and noticed that the file name changed vs the that ofthe same episode I downloaded in Dec and no longer includes the lesson title in the file name.

The new file for the又 又 episodeI downloaded also seems to be playing on my phone now so I'm not sure what has changed, but it seems to be working now. Was there a change in some of the files since the end of last year?

There were many Qing Wen episodes that I noticed this issue with but didn't really track them at the time as I would just skip forward to an episode that worked. To get you some more info will try going through the files I downloaded in Dec/Jan and see where the issues exist then try re-downloading the newer versions to see if that helps.